Microsoft 365 Service Issues

Incident Report for Trillium Family Services

Resolved

Microsoft Update: We’ve confirmed that service restoration is complete. We identified that the issue was caused by elevated service load resulting from reduced capacity during maintenance for a subset of North America hosted infrastructure.
Posted Jan 22, 2026 - 23:25 PST

Update

Microsoft Update:

Current Status: We're rebalancing traffic across all affected infrastructure to ensure the environment enters into a balanced state. We’re proceeding as quickly as possible and this approach will help us identify any additional actions needed for recovery.
Posted Jan 22, 2026 - 15:24 PST

Update

Microsoft Update

Current status: While we've restored the affected infrastructure to a heathy state, further load balancing is required to mitigate persistent impact. We've identified and are implementing additional actions to direct traffic to additional healthy sections of infrastructure to achieve recovery.
Posted Jan 22, 2026 - 13:29 PST

Update

A portion of dependent service infrastructure in the North America region is not processing traffic as expected.

Some of the impacted service functions include, but may not be limited to:
> Sending and receiving email
> Accessing service portals
> Searches within OneDrive and/or SharePoint
Posted Jan 22, 2026 - 12:54 PST

Identified

Microsoft is investigating issues impacting multiple Microsoft 365 services, including Outlook.
Posted Jan 22, 2026 - 12:51 PST
This incident affected: Communications Systems (E-mail / Calendar Services) and External Resources (Office 365 Portal).