Credible Connectivity Issue

Incident Report for Trillium Family Services

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 12:06 PDT

Investigating

Some staff are experiencing connectivity issues when attempting to access Credible and are unable to login. We have reached out to the vendor and will provide an update when we have more information.
Posted Apr 02, 2026 - 10:59 PDT
This incident affected: Applications (Credible EHR).