Currently, some customers are still experiencing slower system performance during business hours. Our investigation found that this is being caused by unusually high volumes of repeated web service export activity from a small number of customers sharing the same server environment. These exports were running frequently throughout the day and placed a heavy load on system resources, which in turn is affecting performance for other customers on those servers.
Corrective Actions Being Taken To stabilize performance and reduce the likelihood of recurrence, we are working directly with the customers to: • Review and optimize their export configurations to eliminate unnecessary or duplicative daytime runs. • Provide guidance on scheduling large or bulk exports during off peak hours, when system demand is significantly lower. • Recommend ways to narrow data ranges and streamline queries to reduce processing load. • Establish follow up conversations to ensure ongoing alignment with export best practices.
Posted Mar 09, 2026 - 13:39 PDT
Investigating
Some users may experience latency or system slowness with Credible. The vendor is investigating the issue.
Posted Mar 04, 2026 - 13:15 PST
This incident affected: Applications (Credible EHR).