Remote Access Latency / Slowness

Incident Report for Trillium Family Services

Resolved

This incident has been resolved.
Posted May 21, 2026 - 09:29 PDT

Monitoring

The vendor believes that the issues affecting connectivity and latency have been resolved. We are continuing to monitor.
Posted May 19, 2026 - 07:56 PDT

Update

We are continuing to engage with the VPN services vendor and have also brought the circuit provider into the discussions. The two vendors are reviewing data and logs in an effort to determine the cause of the latency issues.
Posted May 15, 2026 - 10:41 PDT

Investigating

It appears that latency issues have returned. We have alerted the vendor.
Posted May 14, 2026 - 09:29 PDT

Monitoring

Vendor has fixed the issue causing latency, we are monitoring the connection.
Posted May 13, 2026 - 22:41 PDT

Investigating

We are working with the vendor to investigate reports of latency and slowness accessing files and services while connected to the VPN.
Posted May 12, 2026 - 12:34 PDT
This incident affected: Remote Access (VPN) (Harmony SASE (Perimeter 81)).