Global Amazon Web Services (AWS) Outage

Incident Report for Trillium Family Services

Resolved

Amazon has resolved issues with AWS.
Posted Oct 21, 2025 - 06:32 PDT

Update

The AWS outage is impacting multiple Credible services. You may experience disruption in PDMP, Data Connector/Extract Services, Attachments/File Uploads, and 270 Eligibility Processing.
Posted Oct 20, 2025 - 13:42 PDT

Investigating

Amazon is currently experiencing issues with AWS which may in turn affect many websites and services that use AWS back-end services.
Posted Oct 20, 2025 - 09:01 PDT
This incident affected: Network Connectivity (Internet Connectivity).