PowerBI Reports Not Refreshing

Incident Report for Trillium Family Services

Resolved

The issue has been resolved and PowerBI datasets have been sync'd manually.
Posted May 21, 2026 - 10:51 PDT

Investigating

We are currently investigating this issue.
Posted May 21, 2026 - 09:33 PDT
This incident affected: Applications (Other).