Network Issues (Salem/Albany)

Incident Report for Trillium Family Services

Resolved

This incident has been resolved.
Posted Sep 08, 2026 - 18:12 PDT

Monitoring

The circuit vendor has identified a routing error, and a fix has been implemented. We are testing to ensure the issues have been resolved.
Posted Sep 08, 2026 - 13:51 PDT

Investigating

We are investigating network issues affecting Salem and Albany locations. A support ticket has been opened with the circuit provider.
Posted Sep 04, 2026 - 11:40 PDT
This incident affected: Network Connectivity (Campus Connectivity (WAN)).