Corvallis Campus External Phone Circuit Issues
Incident Report for Trillium Family Services
Update
Phone circuits are operational again. We are still working with the vendor to determine the cause of the intermittent outages.
Posted Jan 01, 2025 - 10:22 PST
Investigating
Corvallis external phone circuits are down again. We've notified the vendor and will be asking them to perform more intrusive testing to determine the cause in order to prevent this from continuing to happen.
Posted Dec 31, 2024 - 14:04 PST
This incident affects: Phone Systems (External Phone Circuits).