Preliminary root cause: A recent update to a portion of network infrastructure in the US West region introduced a misconfiguration which interrupted the process by which IP ranges connect requests with downstream services, leading to impact.
Final status: We’ve completed reverting the networking update and confirmed through service telemetry and customer reports that this issue is resolved.
Posted Jul 23, 2026 - 14:18 PDT
Investigating
Title: Issues accessing or using Microsoft 365 services in the North America region
User impact: Users may be experiencing issues accessing or using Microsoft 365 services in the North America region.
Current status: We are continuing our investigation and are reviewing recent changes for potential correlation while we analyze service telemetry and available diagnostic data.
Scope of impact: Users accessing Microsoft 365 services through affected network paths in the North America region may be impacted.
Posted Jul 23, 2026 - 11:38 PDT
This incident affected: Communications Systems (E-mail / Calendar Services) and External Resources (Office 365 Portal).