PowerBI Data Refresh Issues

Incident Report for Trillium Family Services

Resolved

The portion of service infrastructure responsible for facilitating user access to Power BI and Microsoft Fabric was operating in a suboptimal state and causing impact. We've confirmed through extending monitoring and with previously affected customers that the issue is now resolved.
Posted Oct 21, 2025 - 14:21 PDT

Update

Update from Microsoft: We've identified that the portion of service infrastructure responsible for facilitating user access to Power BI and Microsoft Fabric is operating in a suboptimal state and causing impact. We've rebalanced request traffic and are reviewing our service health telemetry to ensure that the impact is remediated.
Posted Oct 21, 2025 - 11:09 PDT

Update

Microsoft is continuing to analyze the available telemetry data to determine the source of the issue. We’ll provide additional information as it becomes available.
Posted Oct 21, 2025 - 09:55 PDT

Investigating

Microsoft is investigating issues with PowerBI data refresh. Users may experience issues with data refresh in Power BI. Scheduled and manual refreshes may fail to complete.
Posted Oct 21, 2025 - 09:01 PDT
This incident affected: Applications (Other).